This site required the latest verson of flash to be installed on your machine.